HIPAA Compliance with Internet Explorer

-->January 20, 2016Billing & Compliance Alerts

    As of January 12, 2016, Microsoft Windows will only support the most current version of their web browser, Internet Explorer 11. This means that all versions of Internet Explorer, 10 and below, will no longer receive support or security updates through Microsoft Windows.  In order for Medac to be HIPAA compliant, we will be modifying our servers to reject all connections from older versions of Internet Explorer keeping us in line with industry standards.  In order to access Medac’s web portals, you must update your version of Internet Explorer to version 11 or use an alternate browser such as Safari, Firefox, or Chrome.

     

    From Microsoft:

    In order to continue to receive security updates, compatibility fixes, and technical support on Windows 7, Windows 8.1 and Windows 10 you will need to upgrade to Internet Explorer 11.  Internet Explorer 11 “offers improved security, increased performance, better backward compatibility, and support for the web standards that power today’s websites and services.”  Microsoft is encouraging their customers to upgrade to stay up-to-date for a faster, more secure experience and prevent vulnerabilities that may cause malware. This upgrade will help keep your data safer.

     

    •  MEDAC – Committed to Continuing Client Education  •

    The information presented herein reflects general information that is current as of the date it was first published.  In light of changes that may occur in the health care regulatory and compliance environments, the author’s presentation of this information might become outdated.  Please check with your individual legal and/or compliance advisor(s) prior to taking any significant actions based upon the information and advice presented.